5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

【Java/C/PHP/Perl/Ruby/Python/TeX】Eclipse M22

1 :デフォルトの名無しさん:2007/01/07(日) 19:43:08
●公式サイト
Eclipse.org home
http://www.eclipse.org/
Eclipse downloads home
http://www.eclipse.org/downloads/

●JDK
JDK 1.4.2
http://java.sun.com/j2se/1.4.2/ja/download.html
JDK 5.0 (1.5.0)
http://java.sun.com/j2se/1.5.0/ja/download.html
JDK 6 (1.6.0)
http://java.sun.com/javase/ja/6/download.html

●関連サイト
Eclipse Wiki (日本語)
http://eclipsewiki.net/eclipse/
eclipse@Wiki プラグイン一覧 (日本語)
http://www10.atwiki.jp/eclipse/pages/7.html
Eclipse Plugins
http://eclipse-plugins.2y.net/eclipse/index.jsp
Eclipse Plugin Central
http://www.eclipseplugincentral.com/index.php

●前スレ
【Java/Callisto/TeX/他】統合開発環境EclipseM21
http://pc10.2ch.net/test/read.cgi/tech/1153492728/

●関連スレ
【初心者】EclipseでJavaの勉強 2時間目【大歓迎】
http://pc8.2ch.net/test/read.cgi/tech/1147444414/

2 :デフォルトの名無しさん:2007/01/07(日) 21:54:45
●Eclipse 3.2
Eclipse 3.2.2 - 2007/02 (Windows Vista サポート)

●Eclipse 3.3
Eclipse 3.3 M5 - 2007/02/09
Eclipse 3.3 M6 - 2007/03/23 (API 凍結)
Eclipse 3.3 M7 - 2007/05/04 (機能完成)

3 :デフォルトの名無しさん:2007/01/10(水) 04:24:48
          ヽ / /⌒\
         /ヽヽ|/⌒\ii|\
       / /ヾゞ///\\|
       |/   |;;;;;;|/ハ \|
             |;;;;//⌒ヽ
             |;/( ^ω^) >>1おっおっおっ乙枯ー
.           |{ ∪  ∪
             |;;ヾ.,____,ノ
             |;;; |
             |;;;;;|
             |;;;;;|



4 :デフォルトの名無しさん:2007/01/10(水) 19:45:01
Eclipse 3.2.1, phpプラグインのPDT v0.7.0 20070101で
エディタの左に行番号が表示されないんだが、これは仕様なのか。
もちろんGeneral >> Text editors で Show line numbers はオンにしている。
phpのEditorには設定項目はなさげだが。

5 :デフォルトの名無しさん:2007/01/10(水) 21:58:15
Eclipse 3.1(日本語化パッチを含め)を使用したいのですが、公式サイトからは既にダウンロードできないみたいです。
#見落としがあるかもしれませんが・・・
どこかでダウンロードできないでしょうか?

申し訳ございませんが、ご存知の方がいらっしゃいましたらご教示ください。

6 :デフォルトの名無しさん:2007/01/10(水) 22:12:37
>>5
http://archive.eclipse.org/eclipse/downloads/
http://archive.eclipse.org/eclipse/downloads/drops/R-3.1-200506271435/index.php
http://archive.eclipse.org/eclipse/downloads/drops/R-3.1.1-200509290840/index.php
http://archive.eclipse.org/eclipse/downloads/drops/R-3.1.2-200601181600/index.php

あのさあ、ダウンロードページの上の方に「For access to archived builds, look here」って
リンクがあるのがどうして見えないのさ?頭悪い?

7 :デフォルトの名無しさん:2007/01/11(木) 01:48:20
>>6
>あのさあ、ダウンロードページの上の方に「For access to archived builds, look here」って
うちの環境だとそのリンク見えない。
AdBlockで消えてるのかもしれんが。


8 :デフォルトの名無しさん:2007/01/11(木) 07:29:46
単にこのページにたどり着けていないだけだろ。
ttp://download.eclipse.org/eclipse/downloads/

9 :デフォルトの名無しさん:2007/01/11(木) 10:03:12
3.3M4って、キーバインドできる機能に「Recenter」ができてる。
Emacsの\C-l。スゲーうれしい。

10 :デフォルトの名無しさん:2007/01/11(木) 11:38:27
emacs使わないがこりゃ便利だな……

11 :デフォルトの名無しさん:2007/01/11(木) 12:35:19
>>9
Emacs でカーソル上下に動かす度に C-l 押す癖があるので
リリースが凄く楽しみだ

12 :デフォルトの名無しさん:2007/01/11(木) 19:30:16
おー、Recenterできるのか。便利だな。
けど、俺は Ctrl+l に補完を設定してしまったのでもう戻れない…。

Alt+/って押しにくくねぇ?

13 :981:2007/01/12(金) 00:08:06
前スレでtexのこと最後に聞いていたものです。
てふは知ってます。ちゃんとコマンドプロンプトから
dvioutやplatexなども使えます。僕は
TexclipseとBlue Note Texを同じものとおもっていました。
どっちもいま入っています。Blue Note texはどのようにして
使うんですか?教えてください

14 :デフォルトの名無しさん:2007/01/17(水) 12:07:33
Thread Titleが変わってる。
PHP/Perl/Ruby/Pythonと来てる


15 :デフォルトの名無しさん:2007/01/17(水) 12:08:27
>>13
設定でLatexコンパイラのパスやdvipsなどのパスを通す。
それやらないと動かない

16 :デフォルトの名無しさん:2007/01/17(水) 12:12:30
久しぶりにアップデートしてみたら
アップデートサイトURLが変更になったことが原因によるエラー。

Eclipseコミュニティも
ころころアップデートサイトURL変更するのやめてくれねえかな?
ものすごい迷惑だし、毎回こんなダイアログが2,3秒置きに10回も表示されると
ものすごくうんざりしてストレスたまるんだけど。

Unable to access "http://download.eclipse.org/dali/update-site/".
Unable to access site: "http://download.eclipse.org/dali/update-site/" [Server returned HTTP response code: "404 Not Found" for URL: http://download.eclipse.org/dali/update-site/.]
Unable to access site: "http://download.eclipse.org/dali/update-site/" [Server returned HTTP response code: "404 Not Found" for URL: http://download.eclipse.org/dali/update-site/.]
Unable to access "http://download.eclipse.org/tools/emf/updates/".
Unable to access site: "http://download.eclipse.org/tools/emf/updates/" [Server returned HTTP response code: "403 Forbidden" for URL: http://download.eclipse.org/tools/emf/updates/.]
Unable to access site: "http://download.eclipse.org/tools/emf/updates/" [Server returned HTTP response code: "403 Forbidden" for URL: http://download.eclipse.org/tools/emf/updates/.]


17 :デフォルトの名無しさん:2007/01/17(水) 12:14:58
それに毎回eclipse.orgにアクセスして
変更したURLをアップデートマネージャーに再登録しないといけないし。

再登録といってもアップデートマネージャーではできず、
「新規フィーチャーを検索」でURLを変更するか
configurationsディレクトリにあるbookmark.xmlを直接いじるかしないといけない。

とにかくこれはきもい。

一括してURLを変更する方法や、新しいURLにリダイレクトくらいしてもいいのに。
なんか腹が立つ。



18 :デフォルトの名無しさん:2007/01/17(水) 12:23:42
Callisto使えばおkという話じゃなくて?

19 :デフォルトの名無しさん:2007/01/17(水) 12:52:23
アップデートマネージャーを使うと、なぜか
アップデートサイトが幾つも生まれる。
しかも重複して。
そのときに古いURLのサイトもリストにでるからウザイ

Calisto使っても同じ。

20 :デフォルトの名無しさん:2007/01/17(水) 14:51:19
俺もEMFのUpdate Siteにアクセスできないから、理由を調べたらURLの変更っぽい。
http://download.eclipse.org/tools/emf/updates/http://www.eclipse.org/modeling/emf/updates/

正直「tools」だろうが「modeling」だろうが
ユーザーからみたらどっちでもいいよ・・・

[Help]-[Software Updates]-[Find and Install...]-[Search for new features to install]から
[Eclipse Modeling Framework (EMF) Update Site]のURL変更ができないのは面倒くさい。

21 :デフォルトの名無しさん:2007/01/17(水) 19:17:21
さらにひどいのは
アップデートマネージャでアップデートするとき、
ネットワークが切断されると延々とダウンロードをしようとして
プログレスバーがそれ以上進行しなくなる。
キャンセル押しても反応しないので仕方が無く強制終了する羽目になる。

22 :デフォルトの名無しさん:2007/01/17(水) 19:51:43
もうわかったから

23 :デフォルトの名無しさん:2007/01/18(木) 01:44:47
eclipse3.1.1でTexlipse1.1.0を使用していますが、bibファイルを
開けず困っています。

新規作成→ファイル→ファイル名test.bibでファイル作成後、
内部エラーが発生して、ファイルを扱えません。

何か解決策ありましたら、ご指南お願いします。

24 :デフォルトの名無しさん:2007/01/18(木) 20:55:21
つかったことがないんでわからんよ。

bibtexか。どうやって開いているのか?
「ファイルの関連付け」はどうなっている?

ちゃんと二回コンパイルしたか?

テキストエディタではちゃんと開けているか?

EclipseでダメならとりあえずWinShellだなw
Winshellで問題ないなら、Eclipseのそのプラグイン側の問題か
作成したプロジェクトのどこかに問題があるか、だな。


それとだが、
具体的にどんなメッセージがでたのか
示さないと、こちらとしては質問に答えにくいぞ。




25 :デフォルトの名無しさん:2007/01/19(金) 22:30:43
Eclipseの自動更新を使ってるんですが
常に起動したときにEclipse3.2.1の更新があると表示されてしまいます
これはインストールのときにミスったのでしょうか
それともこういう仕様なんでしょうか

プロパティは以下のようになっています
バージョン: 3.2.0
ビルド ID: M20060921-0945

26 :13:2007/01/20(土) 12:46:43
>15ちゃんと通しました

27 :デフォルトの名無しさん:2007/01/20(土) 13:28:10
自動更新は重たそうだから使ってないぞ俺は。
ただでさえアップデートマネージャによる後進ですら
フリーズして強制終了、再起動をしいられることがあるというのに。

28 :デフォルトの名無しさん:2007/01/20(土) 13:29:29
>>26
BlueNote Texのほうだけつかえ。
新規プロジェクトもBlueNoteTexで作成し、そこに文書をコピーせよ。
パースペクティブもBlueNoteTex専用のものに切り替えよ。

29 :デフォルトの名無しさん:2007/01/20(土) 20:43:33
PHPEclipse使ってるんだけど、EclipseってLinuxに接続できない?
Linux側のPHPソースをWindowsからそのまま編集したいんだけど・・・

なにやらデバッグは出来るらしい
ttp://www.geocities.jp/maple4estry/eclipse_php.html

30 :デフォルトの名無しさん:2007/01/21(日) 13:38:29
>>29
Linuxへの接続プロトコルは何を使っている? sftpか? scpか? ftpか?



31 :デフォルトの名無しさん:2007/01/21(日) 15:39:37
>>30
sshじゃダメ?

32 :デフォルトの名無しさん:2007/01/22(月) 03:01:04
Aptanaならできる。
Aptanaをインストールするか、プラグインで導入するかすべし
そのかわりプロジェクトは、PHPEclipseとは別のものになる。


もしくは、Sambaを使え。Linux側のPHPソースをSambaサーバで
Windowsから直接アクセスできるようにしておき、
PHPソースがあるディレクトリにEclipseのプロジェクトを作る。

33 :デフォルトの名無しさん:2007/01/22(月) 03:01:55
お勧めはしないが。
ちなみにそれはJavaでは絶対にやってはいけない
と言われている横着行為であるw

コンパイルしてJARやWARで固めてからデプロイ実行するものだからね
あっちは


34 :デフォルトの名無しさん:2007/01/22(月) 12:12:14
>>33
そうか?総合テストならともかく、開発時にwar化して再デプロイなんて、面倒くさくてやってられないが。

35 :デフォルトの名無しさん:2007/01/22(月) 12:22:00
だから開発時は、鯖となるディレクトリを作っておいてTomcatも
ローカルにインストールしてそこで開発する。

いきなり本番のディレクトリを直接弄る奴は諸刃の剣。
しかもコンパイルするたびにWARで固めるなんてアホのやること。

CVSROOTやSubversionリポジトリを本番のディレクトリ
置くのと同じくらい馬鹿


36 :デフォルトの名無しさん:2007/01/22(月) 15:40:59
>>34
おお、なんてことを・・。

それはJava開発で禁止事項とされているというのに。
Tomcatの本にもそれだけは絶対にやめろとかいてあるよ。
>>35の言うとおり、別のディレクトリに開発用スペースを作るのがいい。



37 :デフォルトの名無しさん:2007/01/22(月) 16:37:00
geronimoのプラグイン1.0,1.1両方を扱えるverでgeronimo1.1のサーバ設定
作ってもサーバが起動できない。何故??

38 :デフォルトの名無しさん:2007/01/22(月) 16:53:28
37みたいなのは
http://www-306.ibm.com/software/webservers/appserv/community/
を使ってたほうが幸せだと思う。Geronimoの開発元による無償パッケージで
なにも考えずにgeronimoできるぞ。

39 :デフォルトの名無しさん:2007/01/22(月) 21:01:20
なんて程度の低い話をしているんだ

40 :デフォルトの名無しさん:2007/01/25(木) 12:05:21
DB定義書を管理するのに便利なプラグインてない?
・ER図をグラフィカル表示
・DBごとにDDL生成
・EXCEL出力
あたりができるとうれしい。
Clayは日本語だし便利なんだけど、Proに金がかかるのがちょっと。。

41 :デフォルトの名無しさん:2007/01/25(木) 13:48:33
京都議定書を管理するプラグインがあるのかと
聞いてきたのかと思った。


Eclipsewikiでは見つからなかった?

プラグイン検索では見つからなかった?

42 :デフォルトの名無しさん:2007/01/26(金) 14:35:20
こんなアップデートサイト登録した覚えはねえってのに
なんなんだよこのウザイエラーは。

bookmarks.xmlにはこんなURLなんて存在しねえし。
http://www.eclipse.org/ はこの問題をなんとかしてくれ

Network connection problems encountered during search.
Unable to access "http://download.eclipse.org/technology/ajdt/32/update/".
Unable to access site: "http://download.eclipse.org/technology/ajdt/32/update/" [Server returned HTTP response code: "404 Not Found" for URL: http://download.eclipse.org/technology/ajdt/32/update/.]
Unable to access site: "http://download.eclipse.org/technology/ajdt/32/update/" [Server returned HTTP response code: "404 Not Found" for URL: http://download.eclipse.org/technology/ajdt/32/update/.]
Unable to access "http://download.eclipse.org/tools/emf/updates/".
Unable to access site: "http://download.eclipse.org/tools/emf/updates/" [Server returned HTTP response code: "403 Forbidden" for URL: http://download.eclipse.org/tools/emf/updates/.]
Unable to access site: "http://download.eclipse.org/tools/emf/updates/" [Server returned HTTP response code: "403 Forbidden" for URL: http://download.eclipse.org/tools/emf/updates/.]


43 :デフォルトの名無しさん:2007/01/26(金) 16:10:05
まじで

Eclipseのアップデートマネージャーはイカれているのか?

44 :デフォルトの名無しさん:2007/01/26(金) 17:50:07
エクリプスなんてつかわないと開発できないのか?テイノウども。

エディタとコマンドプロンプトで十分だろ。

45 :デフォルトの名無しさん:2007/01/26(金) 17:54:05
>>44
出来るけど充分ではない。あまりに非効率。

46 :デフォルトの名無しさん:2007/01/26(金) 20:38:16
>>44
こんな時代だというときに、
いまどきそんな釣りに引っかかる奴は(ry


47 :デフォルトの名無しさん:2007/01/30(火) 00:23:51
プラグインをアンインストールするときに
エラーログ(workspace/.log)に

Cannot find unconfigured feature

と出るいみがわかんねえ・・・



48 :47:2007/01/30(火) 00:39:02
これはコマンドラインの話なんだが

uninstallするまえにdisableにしたらうまくいった

>java -cp startup.jar org.eclipse.core.laun
cher.Main -application org.eclipse.update.core.standaloneUpdate -command disabl
e -featureId org.jboss.ide.eclipse.ejb3.feature -version 1.1.0.Beta2
Command completed successfully.

>java -cp startup.jar org.eclipse.core.laun
cher.Main -application org.eclipse.update.core.standaloneUpdate -command uninst
all -featureId org.jboss.ide.eclipse.ejb3.feature -version 1.1.0.Beta2
↑いまこれを実行中

Update Managerでマウスでdisabledにしようとしても
エラーがあって依存関係がどうこうでうまくいかなかったのに。
で、依存元を調べると、なぜか相互依存しやがっている。
どこかで壊れているのだろう。

GUIではうまくいかないことが、
なぜかコマンドラインではうまくいくというのがEclipseのアップデートマネージャーの仕様なのか?

49 :デフォルトの名無しさん:2007/01/30(火) 13:57:03
uninstallも成功した

50 :デフォルトの名無しさん:2007/02/01(木) 03:09:40
こーいうIDEで外部エディタを利用すると、
恩恵ってかなり減っちゃいますかね。
できれば使い慣れたものを使い続けたいのですが。

51 :デフォルトの名無しさん:2007/02/01(木) 04:21:24
俺Emacs使ってたからよく間違えていらいらしてる

52 :デフォルトの名無しさん:2007/02/01(木) 14:03:04
Emacs風キーバインド使っても?

53 :デフォルトの名無しさん:2007/02/01(木) 14:38:39
うっかりjdkの1.5でなく1.6のほうを導入しちゃったんですが、
eclipseで使うには1.5もインストールしたほうがいいですか?
あるいは、初心者が使う機能(java, eclipse共)の範囲なら、
1.6でも問題なく使えたりしますか?

54 :デフォルトの名無しさん:2007/02/01(木) 14:57:02
1.6で問題ない。

なお、Eclipseは、作ったプログラムを動かすために使うJava VMとして複数の
バージョンを管理できるので、1.5も一緒にインストールしても構わない。

(Eclipseを起動したときに意図しないJava VMで起動してしまう場合は、
Eclipseのショートカットを作って、プロパティのコマンドラインに
「-vm VMへのパス」引数を加える。)

どのJava VMを使おうと、コンパイル作業はEclipse自身が持っているコンパイ
ラ(1.6までの各バージョン対応)がやる。これはプロジェクトごとに指定できる。


55 :デフォルトの名無しさん:2007/02/01(木) 15:15:30
なるほど。回答サンクスです。

56 :デフォルトの名無しさん:2007/02/01(木) 15:29:28
>>52
余計ひどい目にあう(最初から微妙に違うし、そもそも豪腕カスタマイズ済みだし orz)


57 :デフォルトの名無しさん:2007/02/01(木) 18:06:20
ギャルゲー大好きそうなキモアニヲタさんがつくったEmacs
プラグインはどうよ


58 :デフォルトの名無しさん:2007/02/01(木) 18:09:19
ハァ?


59 :デフォルトの名無しさん:2007/02/01(木) 23:02:01
EE2Eだろ。あいつ顔きもいのに@ITとかに自分の写真よく出すよな。
あの顔で写真を載せようとする神経が分からん。
人は見た目が9割。

60 :デフォルトの名無しさん:2007/02/02(金) 01:58:03
三行目に爆笑した

61 :デフォルトの名無しさん:2007/02/02(金) 09:00:57
でも真理だし。

62 :デフォルトの名無しさん:2007/02/02(金) 14:37:40
10割だろ?


63 :オウム教:2007/02/02(金) 14:53:22
騙ってもよいですかな?

64 :デフォルトの名無しさん:2007/02/02(金) 16:43:51
それただの本の題名では…。

65 :デフォルトの名無しさん:2007/02/02(金) 17:58:34
だから爆笑したんだよ

66 :デフォルトの名無しさん:2007/02/02(金) 18:24:38
Eclipse3.2.2はもうそろそろだな。
今月のいつ頃リリースなるか?

http://www.eclipse.org/eclipse/development/freeze_plan_3_2_2.html


67 :デフォルトの名無しさん:2007/02/02(金) 18:28:54
http://www.eclipse.org/ からダウンロードできる
Eclipse Distros ってやつは、
名前の通りただのディストリビューションってことだな?

つまり、Linuxのディストリビューションのように
カーネルだけはリーナストーバルズの指示で開発し
それ以外は各種ディス鳥が開発し
Fedora CoreやDebianやMandrakeやTurboなどの
Linuxのようにそれぞれ仕様が異なるEclipseとなるわけだ。

この解釈で、よろしいかな?

それとも、搭載されているJVMやプラグインが若干違うだけかな?


68 :デフォルトの名無しさん:2007/02/02(金) 18:31:52
Eclipse3.3M4を見たが、
ホワイトスペースが表示されるようになったということは、
JStyleプラグインの必要性も下がりそうだな。
全角空白表示は重要なのでまだまだ下がらないが。

69 :デフォルトの名無しさん:2007/02/02(金) 18:33:21
ワークスペースランチャーから
,metadataで設定されているワーキングセットや
ワークベンチの内容を他のワークスペースにも移行できるのか。

http://download.eclipse.org/eclipse/downloads/drops/S-3.3M4-200612141445/eclipse-news-M4.html

70 :デフォルトの名無しさん:2007/02/02(金) 20:07:58
>>68
必要なのは全角スペースとタブ、それに改行だな
逆に半角スペースは別にいらん

71 :デフォルトの名無しさん:2007/02/02(金) 21:23:40
>>68
改行も区別できんし、見た目が嫌だ。
それぞれの表示のON/OFFもできないし。

72 :デフォルトの名無しさん:2007/02/06(火) 19:33:33
Tomcatプラグイン(Sysdeo)のダウンロードサイト
http://www.sysdeo.com/eclipse/
に行けません。場所が変わったりしたのでしょうか?

73 :デフォルトの名無しさん:2007/02/06(火) 22:47:56
WTP1.5.2って、Callistoからじゃインストールできないのか
Callistoの存在意義って・・・

74 :デフォルトの名無しさん:2007/02/06(火) 22:56:10
>>71
オンオフは外観の設定でできるのではないかと。
フォントの設定の所だと思う

背景色と同一にすればそれでオンオフってか。



それが面倒だから、結局JStylePluginがまだまだ必須なんかな

75 :デフォルトの名無しさん:2007/02/06(火) 22:57:41
>>73
マジ?

おそらくアップデートサイトURLが古いままなんだろうな。
古いアップデートサイトURLが記述されている
をWindowsやfindで検索して、feature.xmlが出てくるので、
そのXMLファイルでアップデートサイトURLを新しいものに
変更すれば最新版がでる、



てことができるかも

WTP最新版はよくわかってないけど。
古いバージョンなら、カリストが使えるはず。


76 :デフォルトの名無しさん:2007/02/06(火) 23:16:35
基本的にCallistoの更新は、各サブプロジェクトが足並みをそろえて一斉に
行われる。最近だとR3.2.1に合わせて去年の9月に行われた。それ以外は
各サブプロジェクトとそのユーザ各自が適宜行う。

既に各サブプロジェクトはeuropeに向けて走っているけど、3.2.x系は
Rational6.1のベースになってるから、あと一回くらいはアップデート
あるんじゃないかなあ。今月3.2.2出るし。

77 :デフォルトの名無しさん:2007/02/06(火) 23:38:26
>>25
漏れも同じ症状

78 :デフォルトの名無しさん:2007/02/07(水) 01:05:39
しばらく使ったけど、いまだCallistoの意味が分からん。
更新サイトはもともとあるし、わざわざこんな名前付ける理由はなんだろう?

79 :デフォルトの名無しさん:2007/02/07(水) 08:25:34
「みんなでタイミング合わせてリリースしようぜ!」
っていうかけ声かけるためのシンボル。
Callisto Simultaneous Releaseって名前だし。
リリース後に意味を求めなくてもいいだろう。

80 :デフォルトの名無しさん:2007/02/07(水) 15:12:13
>>77
自動更新なんて使わない方が良い。
バージョン番号にNがついてるのも無視。
あれやっやったらぶっ壊れる。

>>78
Eclipseが月が太陽を隠す日食であることから、

天文に関する名前って事以外に想像つかない。

木星の衛星だから、
太陽になりかけた惑星ということで、木星を太陽に見立てて・・・

にしてもさすがにカリストは木星に比べて星のサイズがあまりにも小さすぎて食はおこらないな・・・
地球と同じくらいのサイズと言われているが・・・・





81 :デフォルトの名無しさん:2007/02/07(水) 23:52:42
>>80
今年はエウロパだろ。Callisto Simultaneous Release は毎年名前を変える。
木星の月は 60 個以上あるから 60 年以上は持つな。
4大衛星だけかもしれんが。

82 :デフォルトの名無しさん:2007/02/08(木) 07:13:31
>>79
なるほど、CallistoではEclipse本体にリリースタイミング合わせるんだね
単にアップデートサイトを統一するのが目的かと今まで勘違いしていた

83 :デフォルトの名無しさん:2007/02/08(木) 15:23:37
>>81
エウロパはやばいな。不可侵領域だ。人類が手を出して良いものじゃない。
下手に手を出すと、第2の太陽(Sun)が生まれる。

84 :デフォルトの名無しさん:2007/02/08(木) 16:41:11
ネタが古い

85 :デフォルトの名無しさん:2007/02/09(金) 16:59:59
>>81
へえそうなんだ。

>>83
それは天文学的な話をしているのか
それともSunやIBMを取り巻く業界の話をしているのか
どっちなのか説明よろ


86 :デフォルトの名無しさん:2007/02/09(金) 17:01:12
http://ja.wikipedia.org/wiki/Template:User_emacs


WikipediaにEmacsのユーザボックスがあるので
誰かEclipseも作ってくれないかな

にしても、画像ライセンスどれがいいのかわからない



87 :デフォルトの名無しさん:2007/02/09(金) 19:42:10
>>86
eclipse.orgから画像とってくるだけでいいんじゃないのか?

88 :デフォルトの名無しさん:2007/02/09(金) 19:42:54
Microsoft Vista is not a supported platform for Eclipse 3.2.1.
Patches to support Vista were applied to the 3.2.1 stream based
on an early Microsoft Vista release candidate. Subsequent to
the Eclipse 3.2.1 release, a later Vista release candidate required
additional patches to Eclipse. Full Vista support for Eclipse will be
included in Eclipse 3.2.2, scheduled for release in February 2007.


今のEclipseはVistaには対応していないらしい。

Vistaもめちゃくちゃだな




89 :デフォルトの名無しさん:2007/02/09(金) 19:45:17
>>88
この画面はWindows版Eclipseをダウンロードしようとするときに現れる。

90 :デフォルトの名無しさん:2007/02/10(土) 00:36:11
WTPの昔のバージョン(0.7.1のオールインワン)がほしいんだけど、
http://archive.eclipse.org/webtools/downloads/drops/R0.7/R-0.7.1-200509270720/
ここからもうダウンロードできないみたい。

どこか置いてあるミラーサイトを知りませんか?

91 :デフォルトの名無しさん:2007/02/10(土) 14:18:05
CheckStyleで警告内容を調整する細かい設定をいじっていたら
いきなりEclipseがメモリ不足でとまってしまいました。
そしてEclipseを起動しようとすると、エラーが。
おかしいので-cleanオプションで再起動しようとすると、起動できずダイアログにworkspace/.metadata/.logを見よ、
というので見てみると、プラグインに問題があるようで。しかし関係ないエラーと例外が列挙されて意味不明で・・・。
そこで.metadataディレクトリを削除。それでも起動できずエラー内容は変わらず。
そこでconfigurationディレクトリを削除。それでも変わらない。そこで.metadataとconfiguration両方削除。
それでも変わらないので、Eclipseを新規にダウンロードし、既存のEclipseディレクトリに
上書きしました。これで起動するとやっとEclipseが起動しました。
そして既存のワークスペースからプロジェクトをインポートしなおしました。



92 :デフォルトの名無しさん:2007/02/10(土) 14:39:29
    r=、r=、
   __{_0.{ 0.}
  /´l r `'、_,ノi、
 {       )  でっていう
  `、   _.r(_ ノ
   `´-r _ノ)
     / !`i)
    i  i 「ン__r'^i
    /! / (_`!し'i j
    Li、 '、_ツ`ー' /
    __ >、j__  r'
   i'´ Y⌒ヽ ̄}
   `=-{      )

93 :91:2007/02/10(土) 18:11:02
そしたら、やはり、以下のようなメッセージがでるのですね・・・・

Fileset from project "プロジェクト名" has no valid check configuration.

com.atlassw.tools.eclipse.checkstyle.util.CheckstylePluginException: Fileset from project "プロジェクト名" has no valid check configuration.
at com.atlassw.tools.eclipse.checkstyle.builder.CheckstyleBuilder.handleBuildSelection(CheckstyleBuilder.java:289)
at com.atlassw.tools.eclipse.checkstyle.builder.CheckstyleBuilder.build(CheckstyleBuilder.java:212)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:603)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:167)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:201)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:230)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:233)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:252)
at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:285)
at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:145)
at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:208)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

CheckStyleプラグインって壊れやすいんですね・・・


これは、CheckStyleプラグインディレクトリの中身が怪しく、そこが壊れた可能性があるので
CheckStyleプラグインをダウンロードしなおし、上書きして再起動してみました。


そうすると、見事にEclipseが直っていました。バックアップしておいた.metadataディレクトリも
もとの場所に戻して見事に復活です。

余計なプラグインをインストールしなおさずに済みました。
皆さんも気をつけましょう。

94 :デフォルトの名無しさん:2007/02/11(日) 00:19:58
Eclipse 3.3 M5 キター

http://download.eclipse.org/eclipse/downloads/drops/S-3.3M5-200702091006/index.php

95 :デフォルトの名無しさん:2007/02/11(日) 12:57:00
>>94
感想は?

96 :デフォルトの名無しさん:2007/02/11(日) 16:24:27
>>94
宣伝だけしておいて感想なしかよ。

ということで俺が気が付いたことだけ書いてみるか。

スプラッシュにEuropianと書かれているのは
一体なんだ?

97 :デフォルトの名無しさん:2007/02/11(日) 16:28:02
落としてもいないけど:

コーヒー(Java)なら深いロースト。それともカリストの次のエウロパ関連?


98 :デフォルトの名無しさん:2007/02/11(日) 16:30:04
アップデートサイトで新規フィーチャーを検索を選んだら

Europaッ手のが出てきて
選択してみたが

次へボタンを押した直後にこれだ・・・・・
Network connection problems encountered during search.
Unable to access
"http://download.eclipse.org/releases/europa".
Unable to access site:
"http://download.eclipse.org/releases/europa"
[Server returned HTTP response code: "403 Forbidden"
for URL: http://download.eclipse.org/releases/europa.]

Server returned HTTP response code: "403 Forbidden"
for URL: http://download.eclipse.org/releases/europa.

Unable to access site: "http://download.eclipse.org/releases/europa"
[Server returned HTTP response code: "
403 Forbidden" for URL: http://download.eclipse.org/releases/europa.]

Server returned HTTP response code: "403 Forbidden"
for URL: http://download.eclipse.org/releases/europa.



マイルストーンだからといって、まだ存在しない分けか。

99 :デフォルトの名無しさん:2007/02/11(日) 16:31:26
しかも、Javaエディタに警告やエラーのアイコンと波線が
出るのだが・・・エラーメッセージのあの吹き出しがでなくなっているぞ。

肝心なところでバグか?


100 :デフォルトの名無しさん:2007/02/11(日) 16:34:07
>>97
そういうことか
ロースト?

よくわからないが、

ヨーロッパかと思ったら絵迂路派だったw

110 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)