5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

rpm作成スレッド

97 :login:Penguin:03/10/29 02:34 ID:SqMCZ52G
質問です。
libsomething.soを必要とするライブラリをmylib.i386.rpmとして配布したいと思っています。
しかし、libsomething.soはrpmではなくバイナリtar ballで配布されています。
すると、mylib.i386.rpmをインストールする際に libsomething.soを必要としています
と言われ、インストールできません。(Requiresが自動的に設定される)

強引な解決策として、Providesにlibsomething.soを追加すれば一応インストールされるのですが、
これは嘘っぱちなので、本当はやりたくありません。
どうすればいいでしょうか?

85 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)